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1 Software Introduction 

VMP, short for Vision Management Platform, is an application in the brand-new control system COEX series. 
Featuring innovative interaction design and plenty of practical functions, such as device management, input settings, 
screen configuration, display correction, color processing, screen settings, monitoring and maintenance, and preset 
management, it provides users with an efficient and easy operation and control experience. 

 Easy single-device and grouped-device controls 

Devices can be grouped and batch operated as you wish, greatly improving work efficiency. 

 Fast configuration of regular or irregular screens 

Cabinets can be quickly connected, flexibly arranged and aligned, considerably simplifying screen configuration. 

 Distinct topology area and properties areas 

The screen topology is clear at a glance, the input source can be previewed in real time and various properties 
can be easily set. 
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2 UI Introduction 

Figure 2-1 UI Introduction 
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3 Getting Started 

3.1 Install VMP 

Prerequisites 

 The VMP software package is prepared. 

 A computer meeting the following requirements is available. 

− OS: Windows 7 (64 bits) or later 

− CPU: i5 or later 

− RAM: 8 GB or greater 

Installation Method 

Run the Coex VMP Setup.exe file and follow the setup wizard to complete the installation. If a firewall prompt 

appears, choose to allow the installation. 

Installation Result 

If the installation is successful, the VMP software shortcut  appears on the desktop. 

3.2 Start Virtual Devices 

You can start the virtual devices to use the VMP functions when there is no physical device. 

Step 1 From the menu bar, choose Tools > Virtual Device > Start. 

Figure 3-1 Virtual devices 

 

Note 

To stop virtual devices, choose Tools > Virtual Device > Stop from the menu bar, or close VMP and reopen it.. 

3.3 Connect Physical Devices 

3.3.1 Via Ethernet Cable 

Connect the controller and the control PC directly via Ethernet cable and set a static IP address for the controller to 
let the controller and control PC be on the same network segment. The MX40 Pro LED display controller is used as 
an example in this section. 

Step 1 Follow Figure 3-2 to complete the hardware connection. 
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Figure 3-2 Connecting devices via Ethernet cable 

 

Step 2 Press the knob of the controller to enter the menu and choose Communication Settings > Network Settings. 

Step 3 Set Mode to Manual. 

Step 4 Set IP Address, Subnet Mask and Default Gateway and ensure the controller and control PC are on the same 

network segment. 

To reset the network settings to the default values, please select Reset and press the knob. 

Step 5 After the settings, select Apply and press the knob. 

3.3.2 Via LAN 

Connect the controller and the control PC to the same LAN via a router and set the controller to automatically obtain 
an IP address. The MX40 Pro LED display controller is used as an example in this section. 

Step 1 Follow Figure 3-3 to complete the hardware connection. 

Figure 3-3 Connecting devices via LAN 

 

Step 2 Press the knob of the controller to enter the menu and choose Communication Settings > Network Settings. 

Step 3 Set Mode to Auto. 

Step 4 Select Apply and press the knob. 

3.4 Load Cabinet Configuration Files 

Use VMP to load cabinet configuration files (.rcfgx) to let cabinets display the image normally. Before you begin, 
please prepare the cabinet configuration files in advance. 

Step 1 Open VMP. 

Step 2 From the menu bar, choose Tools > Maintain. 

Step 3 Select the Cabinet tab. 

Step 4 In the device list on the left, select the desired controller to show the information about all the cabinets loaded by the 

selected controller. 
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Figure 3-4 Cabinet maintenance 

 

Step 5 Select one or multiple cabinets, click Upload File and from its drop-down options, select Upload Config file. 

Step 6 Select a local file you want to upload and click Open. 

Step 7 After the file is loaded, click Save Rv-card config. 

Step 8 In the displayed dialog box, select Receiving card parameters and click OK. For CX series products, this operation 

is not required. 

Figure 3-5 Saving 

 

3.5 Set Input Source 

Select a desired input source and set its resolution and frame rate. If the resolutions of the input source and screen 
are the same, the image can be displayed pixel to pixel. A lower frame rate may result in image flickering, while a 
higher frame rate helps stabilize the display image. 

Step 1 Select Source. 

Step 2 In the device list on the left, select the desired controller. 

Step 3 Double-click a source thumbnail in the source list at the bottom of the page, or select an option from the drop-down 

list next to Select Source in the properties area on the right to select a source. 

Step 4 Set Resolution and Refresh Rate and click Apply. For an internal source, you can also set the bit depth. For the 

SDI sources, please skip this step. 
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Figure 3-6 Setting input source 

 

3.6 Configure Cabinet Topology 

Configure the cabinet topological diagram to complete the logical connection of the cabinets. 

Step 1 Select Layout. 

Step 2 In the device list on the left, select the desired controller. 

Figure 3-7 Layout 

 

Step 3 From the menu bar, choose View > Display, select a view for the topology area, and select the content to be 

displayed. 

You can also select a view by clicking one of the following icons at top right of the topology area. The selected view 

will have a green spot near it. 

 : Display the cabinets only. 
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 : Display the preview image of the input source only. 

 : Display the cabinets and preview image of the input source at the same time. 

In addition, you can choose to show the cabinet topology, cabinet status, group names, source tags, and overlapping 

cabinets. 

Step 4 In the bottom area of the page, select an Ethernet output port and click the canvas multiple times to add the 

corresponding number of cabinets. 

The cabinets will be automatically connected when you are adding them, as shown in Figure 3-8. The Ethernet port’s 
loading capacity information will be displayed, as shown in Figure 3-9. The properties area will display the cabinet 
information, as shown Figure 3-10. 

Figure 3-8 Cabinets connected automatically 

 

Figure 3-9 Ethernet port capacity 

 

 12/16: Indicates that the controller's Ethernet port 1 drives a total of 16 cabinets and 12 cabinets have been 

connected in the topology diagram. 

 12%: Indicates these 12 cabinets have used 12% of the Ethernet port’s capacity. 

Figure 3-10 Cabinet information 

 

Notes 

If all the cabinets loaded by the Ethernet ports have the same size, you can use the swift layout function to quickly 

add and connect the cabinets for all the Ethernet ports. The operations are as follows: 

At the top right of the Ethernet port list, click . Then, drag the mouse on the canvas to add cabinets that 

match the actual requirements. In the properties area, select a layout and click Done. 

Step 5 Select another Ethernet port and continue to add cabinets until all cabinets are connected. 

Step 6 For cabinets that have the same size and consecutive serial numbers, if you want to change the cabinet connection 

topology, select the cabinets and then select a quick topology under Quick topo in the properties area, as shown in 

Figure 3-11. For other cabinets, skep this step. 
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Figure 3-11 Quick topology 

 

Step 7 Do any of the following to arrange and align the cabinets to let the cabinet positions meet the display requirements. 

 Use the function buttons 

 

− 1:1: The canvas size equals to the input source resolution. 

− Zoom To Selection: The selected element is zoomed and displayed in the center of the canvas. 

− Fit Screen: The canvas size is automatically adjusted to fit the topology area size. 

The drop-down menu of  is shown in the figure below. The menu can be used to set the canvas grid. 

 

 Grid: When the switch is , a grid is displayed on the canvas. If you do not need to display the grid, click 

 to change it to , or set the switch to . 

 Color: Set the grid color. 

 Spacing: Set the spacing of horizontal and vertical lines of the grid. 

 Snap To Cabinet: When you move a cabinet close to another cabinet, the moved cabinet will be snapped to 

the edge of the other cabinet to avoid gaps. 

 Snap To Grid: The cabinet will be snapped to the grid. 

 Use the function menus on the menu bar 

− Edit menu 
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− View menu 

 

 Use the right-click function menus 

− Right click the canvas 

 

Zoom To Controller: The selected controller is zoomed and displayed in the middle of the topology area. 

− Right click the cabinet 

 

Select String: Select all the cabinets on the connection line of the current cabinet. 

Switch: Switch the display areas of two cabinets. 

Group: Group the selected cabinets. To set the group name and color, please select the group and set them 

in the properties area. 

Ungroup: Ungroup the cabinets. 

Add to Group: Add the selected cabinets to a group. 

 Set cabinet coordinates and rotation 

Select a cabinet and set its coordinates and rotation angle in the properties area. After the cabinet is rotated, the 
input source will be rotated by the set angle and displayed. 

 

Step 8 After setting, right-click the controller in the device list and select Save Rv-card config. For CX series products, no 

saving operation is required. 

Step 9 Click Save in the displayed dialog box. 

3.7 Control Display Status 

Set the display loaded by the controller or cabinets to a black screen or frozen status. 

 Blackout: Make the output screen go black. The input source is played normally. 

 Freeze: Make the output screen always display the current frame. The input source is played normally. 
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Set the Status of Display Loaded by the Controller 

 At the top left of the page, click Blackout or Freeze. 

 

 In the device list on the left, right-click the controller and select Blackout or Freeze from the pop-up menu. 

 

Set the Status of Display Loaded by Cabinets 

Select Layout and do any of the following: 

 Select one or more cabinets, and set the Blackout or Freeze switch to  in the properties area. 

 

 Right click a cabinet and select Blackout or Freeze from the pop-up menu. 

 

 Select Monitor and set the Blackout or Freeze switch to  in the properties area. 
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4 Device Management 

4.1 Export and Import Project Files 

Export the project files (.nprj) of devices or device groups so that you can import the files to apply the configuration 
data to the same kind of devices, improving the configuration efficiency. 

Export Project Files 

Step 1 From the menu bar, choose Project > Export and select a device or device group. 

You can also right click a device or device group in the device list and select Export from the pop-up menu. 

Step 2 Select a local directory and click Save. 

Step 3 After successful export, click OK to close the prompt box. 

Figure 4-1 Successful export 

 

Import Project Files 

Step 1 From the menu bar, choose Project > Import to and select a device or device group. 

You can also right click a device or device group in the device list and select Import from the pop-up menu. 

Step 2 Select a local project file and click Open. 

After successful device matching, a dialog box as shown in Figure 4-2 is displayed. 

Figure 4-2 Matching devices 

 

Step 3 Click OK. 

Step 4 After successful import, click OK to close the prompt box. 
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Figure 4-3 Successful import 

 

4.2 Manage Device Groups 

Create a group and add devices to manage the grouped devices uniformly and perform some batch operations. 
When the property values of the devices in the group are different, the value will be displayed as Mix. 

Step 1 In the device list area, click  to enter the group management page. 

Figure 4-4 Group management 

 

Step 2 Click  to create a group, enter a group name and press Enter or click on the other position on the page. 

To rename a group, right-click the group, select Rename from the pop-up menu and enter a new group name. 

Step 3 Drag the target devices to the created group. 

Devices of the same series can be added to the same group, for example, MX series products. 

Figure 4-5 Adding devices 

 

Step 4 After the settings, click . 

 To delete a device in a group, drag the device out of the group. 

 To delete a group, right-click the group, select Remove group from the pop-up menu. 
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Note 

You can set the Mapping switch to  to enable the mapping function. 

4.3 Set Backup Device 

Set a primary controller and backup controller so that the backup controller can take over the primary controller when 
it fails. 

Step 1 From the menu bar, choose Tools > System Backup to open the System Backup dialog box. 

You can also right click a device or device group in the device list and select System backup from the pop-up menu 

to open the System Backup dialog box. 

Figure 4-6 System backup 

 

Step 2 Select a primary controller and a backup controller from the drop-down options respectively, and then click Add. 

The backup list will display the added backup information. To delete the backup information, click . 
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Figure 4-7 Backup list 

 

Step 3 After the settings, click OK. 

4.4 Switch Working Mode 

In the device list on the left, right click a device and select Working Mode from the displayed menu. On the displayed 
dialog box, select All-In-One Controller or Send-Only Controller and click OK. 

Figure 4-8 Working mode 
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5 Input Source Configuration 

This chapter describes input source configuration with one device selected. 

5.1 Set External Sources 

Select Source and double-click a source thumbnail in the source list at the bottom of the page, or select an option 
from the drop-down list next to Select Source in the properties area on the right to select a source. Then, perform the 

following operations based on your actual needs. 

View Source Information 

View the attribute values of the input source. 

Figure 5-1 Source information 

 

Set Resolution and Frame Rate 

If the resolutions of the input source and screen are the same, the image can be displayed pixel to pixel. A lower 
frame rate may result in image flickering, while a higher frame rate helps stabilize the display image. 

Select a value from the drop-down lists of Resolution and Frame Rate and click Apply. 

Figure 5-2 EDID 

 

Adjust the Color 

Step 1 In the InfoFrame Override area, select a value from the drop-down lists of Color Space/Sampling, Gamut and 

Quantization Range. 

The override parameter will be used in the calculation of color adjustment. Select From Input and the software will 

read the attribute value that comes with the input source. 

Figure 5-3 InfoFrame Override 

 

Step 2 In the Color area, drag the sliders to adjust the parameter values. 

Black Level is used to adjust the contrast of the dark areas of the image. 
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Figure 5-4 Color 

 

Set HDR Parameters 

Select an HDR format from the drop-down list of Format and set related parameters. Select Auto and the software 

will read the attribute value that comes with the input source. 

Figure 5-5 HDR 

 

HDR parameters: 

 PQ mode: The mapping method of video source brightness. 

− ST2084 (PQ): This mode 1:1 maps the brightness of the video source. The part that exceeds the maximum 

screen brightness will still be displayed as the maximum screen brightness. 

− ST2086 (Linear mapping): This mode linearly maps the brightness of the video source. It globally adjust the 

video source brightness according to the maximum screen brightness to ensure that the ratio of the 

brightness of the entire source content remains unchanged. 

 MaxCLL: The override value of the maximum video source brightness. MaxCLL takes effect when Override is 

selected. 

5.2 Set Internal Sources 

Select the internal source and set the related parameters for screen testing and troubleshooting. 

Step 1 Select Source. 

Step 2 Double-click the thumbnail of internal source in the source list at the bottom of the page, or select Internal Source 

from the drop-down list next to Select Source in the properties area on the right. 

Step 3 Select an image. 

 Imported images 

XI'
AN
 N
OV
AS
TA
R T
EC
H 
CO
., L
TD
.



 VMP Vision Management Platform User Manual  
   

 

www.novastar.tech   17 
 

 

These images are imported via . 

 Static images 

These images come with VMP, as shown in the figure below. 

 

 Dynamic images 

These images come with VMP, as shown in the figure below. 

 

Step 4 Set the resolution, frame rate and bit depth for the internal source. 

Figure 5-6 Internal source parameters 

 

Step 5 After the settings, click Apply. 

5.3 Set Layers (All-In-One Controller Mode Only) 

Add layers and set the layer properties. The maximum number of layers that can be added depends on the 
connected device. 

Step 1 Select Source. 
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Figure 5-7 Input source 

 

Step 2 In the properties area, set the canvas size. 

Step 3 At the top right of the topology area, select  so that only the input preview image is displayed and the cabinets 

are not displayed. 

Step 4 Double click a source thumbnail at the bottom to add layers. 

 Switch source 

− Select a layer and select another source in the properties area. 

− Right click a layer, select Source from the displayed menu, and select another source. 

 Adjust layer size and position 

− Select a layer and set the layer size and coordinates in the properties area. You can also bring the layer to 

front or send it to back, and lock the layer. 

− Right click a layer and select Bring to Front, Send to Back, Bring Forward or Send Backward from the 

displayed menu. 

− At the top right of a layer, click a function icon to set the layer. 

: Lock the layer. 

: Unlock the layer. 

: The layer size is the same as the input source resolution. 

: The layer size changes automatically according to the canvas size. 

: Delete the layer. 

 Set borders 

Select a layer and enable or disable the layer borders function in the properties area. After enabling the function, 
you can set the border thickness and color. 

 Crop the input source 

Select a layer and enable or disable the crop function in the properties area. After enabling the function, you can 
set the crop size and position. 
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6 Screen Configuration 

This chapter describes screen configuration with one device selected. 

6.1 Configure Screen Topology 

For details, see 3.6 Configure Cabinet Topology. 

6.2 Set the Cabinet 

Select Layout, select one or more cabinets and do any of the following operations in the properties area. 

Figure 6-1 Test pattern 

 

Control Display Status 

Set the Blackout or Freeze switch to . 

Enable Indicator 

Set the Indicator switch to  to enable the running status indicator of the cabinet. 

Enable the Light Up Slowly Function 

Set the Light up slowly switch to  so that after the screen is powered on, the display brightness will slowly 

change from 0 to the target value. 

Set Test Pattern 

Select a test pattern from the drop-down list of Test Pattern to perform screen aging test and troubleshoot problems. 

Set Preset Image 

Select an option from the No Data signal drop-down list. 

 Blackout: The output screen displays a black image. 

 Last Frame: The output screen always displays the last frame. 

6.3 Enable Ethernet Port Redundancy 

Select Layout and set the Ports Redundancy switch to . 

Figure 6-2 Ethernet port backup 
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7 Display Correction 

This chapter describes display correction with one device selected. 

7.1 Correct Seams 

Adjust the seams between cabinets or modules to improve the visual experience. 

Step 1 Select Correction. 

Step 2 On the Seams tab page in the properties area, set the Seam Correction switch to   

Step 3 Set the parameters in the Display area. 

Figure 7-1 Display content (seams) 

 

 Calibration: Set the Calibration switch to  to make the screen apply the calibration effect made by the 

calibration platform. 

 Brightness: Adjust the display brightness. 

 Image: Set which image the screen displays. To display the image of current input source, click  and hold it. 

Step 4 Select a correction mode. 

Figure 7-2 Selecting mode (seams) 

 

 Cabinet Seams: Correct the seams of cabinets. 

 LDM Seams: Correct the seams of modules. 

Step 5 When correcting the module seams, if you need to overwrite the numbers of module columns and rows, set the 

Cabinet Structure switch to  and set the numbers. Otherwise, skip this step. 

Figure 7-3 Cabinet structure 

 

Step 6 In the topology area, click or click and drag the mouse to select the seams to be corrected. 

Step 7 Set the adjustment parameters. 
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Figure 7-4 Set the parameters. 

 

 Quick adjust: Has a large range of adjustment. 

 Fine adjust: Has a small range of adjustment. 

 Hide cursor on screen: When the switch is , use the keyboard shortcuts to adjust the seams and the cursor 

will not be displayed on the screen. 

Step 8 Place the mouse on the scroll wheel icon and adjust the brightness by dragging the wheel icon up or down, scrolling 

the mouse wheel, or using the keyboard shortcuts 4+↑/↓. 

 Restore: Restore the configuration to the last saved. 

 Reset: Reset the configuration to the status before adjustment. 

Step 9 After the settings, click Save. 

7.2 Correct Multi-Batch Cabinets/Modules 

Adjust the chroma of cabinets or modules from multiple batches to make the overall chroma of the display more 
balanced and uniform. 

Step 1 Select Correction. 

Step 2 Select the Modules tab in the properties area. 

Step 3 Set the display content. 

Figure 7-5 Display content (multiple-batch) 

 

 Calibration: Set the Calibration switch to  to make the screen apply the calibration effect made by the 

calibration platform. 

 Brightness: Adjust the display brightness. 

 Image: Set which image the screen displays. To display the image of current input source, click  and hold it. 

Step 4 Select a correction mode. 
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Figure 7-6 Selecting mode 

 

 Cabinet: Correct the multi-batch cabinets. 

 LDM: Correct the multi-batch modules. 

Step 5 When correcting the multi-batch modules, if you need to overwrite the numbers of module columns and rows, set the 

Cabinet Structure switch to  and set the numbers. Otherwise, skip this step. 

Figure 7-7 Cabinet structure 

 

Step 6 In the topology area, click or click and drag the mouse to select the cabinets or modules to be corrected. 

Step 7 Drag the slider to adjust chroma. 

Figure 7-8 Adjustment 

 

 Restore: Restore the configuration to the last saved. 

 Hide cursor on screen: When the switch is , use the keyboard shortcuts to adjust chroma and the cursor will 

not be displayed on the screen. 

Step 8 After the settings, click Save. 
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8 Color Processing 

This chapter describes screen correction with one device selected.  

8.1 Color Replacement 

Replace a color with another color according to the settings. 

Step 1 Select Processing. 

Step 2 Set the Color Replacement switch to . 

Step 3 Set the colors before and after replacement. 

 Method 1: Click the color area in  to open the color palette and set a color. 

 Method 2: Click the eyedropper in  and select a color in the topology area. 

Figure 8-1 Color Replacement 

 

Step 4 Set Hue Tolerance, Hue Softness, Shadow Strength and Skin tone Protect. 

 Hue Tolerance: Indicates the hue range of the color to be replaced. The larger the value, the larger the 

replacement area. 

 Hue Softness: Indicates the hue softness of the transition area. 

 Shadow Strength: Indicates the gradient parameter of the highlight or shadow area. The larger the value, the 

smoother the gradient. 

 Skin tone Protect: Keeps the skin tone as original as possible. 

8.2 14CH Color Correction 

Select Processing and set the 14CH Color Correction switch to . Click a value of a color to enable the editing 

status and change the value, , for example. 
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Figure 8-2 14CH Color Correction 

 

8.3 Set Curves 

Adjust the curves. 

Step 1 Select Processing. 

Step 2 Set the Curves switch to . 

Figure 8-3 Curves 

 

Step 3 Select the white, red, green or blue channel. 

Step 4 Drag the slider under the curve diagram to set the curve adjustment range. 

Step 5 Click on any position of the curve to add an adjustment point and drag the point to adjust the curve. 

Input and Output indicate the absolute coordinates of the adjustment point in the curve diagram. 

To delete the adjustment point, drag the point outside the curve diagram, or select the point and press Delete. 
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8.4 Enable 3D LUT 

A set of mapping relationships are defined in the 3D LUT file (.cube) to adjust the colors of the video source. Before 
you begin, please prepare a 3D LUT file in advance. 

Step 1 Select Processing. 

Step 2 Click anywhere in the Load 3DLUT file area, select a file and open it. 

Figure 8-4 Loading 3D LUT file 

 

Step 3 Set the 3D LUT switch to  and drag the slider to adjust the level of applying the 3D LUT. 

Figure 8-5 Adjusting intensity 

 

To delete the file, click . 

8.5 Enable Dynamic Booster 

Dynamic Booster can significantly improve the display contrast and image details for better visual experience and 
effectively control and lower the display power consumption. 

Select Processing and set the Dynamic Booster switch to  and drag the slider to adjust the level of applying 

the Dynamic Booster. 

Figure 8-6 Dynamic Booster 
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9 Screen Settings 

This chapter describes screen settings with one device selected. 

9.1 Adjsut Image Quality 

9.1.1 Adjsut Brightness 

Select Screen Settings. On the Image Quality tab page, set the brightness, maximum brightness and gamma 
values, and enable or disable Current Dimming as needed.  

The maximum brightness takes effect when Override is selected. When Current Dimming is enabled, the screen 

brightness will be reduced, but it can improve the flicker issue in low brightness conditions. 

Figure 9-1 Adjusting brightness 

 

9.1.2 Set LED Image Booster 

Note 

Before you begin, please complete screen calibration first. 

 

Select Screen Settings. On the Image Quality tab page, select an output color gamut from the Gamut drop-down 
list, drag the slider to adjust color temperature, and enable or disable Magic Gray as needed. 

The output gamut options include standard gamuts, custom gamut, the original screen gamut and the input gamut 

(From input). To change the custom gamut, click , select a gamut in the properties area on the color gamut 

diagram, and adjust the red, green, blue and white parameters based on the selected gamut. 

Figure 9-2 LED Image Booster 

 

9.1.3 Apply Calibration Effect 

Note 

Before you begin, please complete brightness and chroma calibration of the screen and upload the coefficients. 

 

Select Screen Settings. On the Image Quality tab page, set the Calibration switch to  to make the screen 

apply the calibration effect made by the calibration platform. 
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Figure 9-3 Calibration 

 

9.1.4 Set Thermal Compensation 

Note 

Before you begin, please complete thermal calibration of the screen and upload the temperature coefficients. 

 

Select Screen Setting. On the Image Quality tab page, drag the slider to adjust the degree of applying the 

temperature coefficients. 

Figure 9-4 Thermal compensation 

 

9.1.5 Adjust EOTF 

Select Screen Settings. On the Image Quality tab page, drag the slider to adjust the shadow compensation value. 

Figure 9-5 Shadow compensation 

 

9.2 Set Output 

9.2.1 Set Output Bit Depth 

Select Screen Settings and then select the Output tab. Under Video, select an option from the drop-down list of Bit 
Depth. If Auto is selected, the output bit depth is the same as the input bit depth. 

Figure 9-6 Output bit depth 

 

9.2.2 Set Low Latency 

Select Screen Settings and then select the Output tab. Under Video, do any of the following operations as needed. 

Figure 9-7 Low latency 
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Enable Low Latency 

Set the Low Latency switch to  to enable the low latency function. 

Set Additional Frame Latency 

When the controller works with high-latency devices, the latency needs to be increased. You can set the Low 

Latency switch to  and set a value for Additional Frame Latency. 

9.2.3 Set Sync Parameters 

Select Screen Settings and then select the Output tab. Under Sync, select a synchronization signal for the display 

frame rate and set the phase offset. 

Figure 9-8 Sync 

 

 Active Source: Sync with the frame rate of the active source. 

 Genlock: Sync with the frame rate of the Genlock signal. When the shutter shit function of the controller is 

effective, please select this option. In addition, the controller and the camera need to use the same Genlock 

signal generator. 

 Internal: Sync with the frame rate of the controller's internal clock. 

9.2.4 Set Frame Multiplication 

Frame multiplication can make the screen output multiple frames within the original one frame time and provide them 
to different cameras. 

Select Screen Settings and then select the Output tab. Near Frame Multiplication, set its switch to  and set 

the number of frames and the display mode of each frame. 

Figure 9-9 Frame multiplication 

 

Take the above figure as an example. The parameters are described as follows: 

 Frame Multiplication: After the current frame rate (59.94) is multiplied by 3, it is 179.82 Hz. Three frames are 

output in 1/59.94 second. 

 Video: The first and second frames display the input source image. The first frame displays the image from the 

coordinates (0, 0) and the second frame displays the image from the coordinates (1920, 0). 

 Color: The third frame displays a pure white image. 

9.2.5 Set Shutter Fit 

The display can fit the camera shutter to make the picture shooting have a better effect. This requires that the sync 
signal must be Genlock and the controller and camera need to use the same Genlock signal generator. 
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Select Angle or Speed and set the parameter value. 

Select Screen Settings and then select the Output tab. Near Shutter Fit, set its switch to  and set the related 

parameters. 

Figure 9-10 Shutter fit 

 

9.2.6 Enable 3D Function 

Select Screen Settings and then select the Output tab. Near 3D, set its switch to  and set the related 

parameters. 

Figure 9-11 3D 

 

 Source Format: Set the format of the 3D video source. Set the format to Side-by-Side, Top-and-Bottom or 

Frame Sequential according to the format of the accessed video source. 

 Right Eye Offset: Set the start position of the right eye image. When the video source format is side-by-side or 

top-and-bottom and the left and right eye images are provided, this parameter can be set. 

 Eye Priority: Set which image is sent first, the right eye image or the left eye image. Wear the 3D glasses to 

watch the display. If the display is abnormal, set the parameter value to the other one. If the display is normal, 

the setting is done. 

 3rd Emitter: When a third-party 3D signal emitter is used, set the switch to . 

 Emitter Delay: Set the delay time of sending the synchronization signal from the 3D signal emitter to the 3D 

glasses. This setting ensures that the switching between left and right eye images of the 3D glasses is in sync 

with the switching between the left and right eye images on the display. This parameter is applicable to both the 

NovaStar and third-party emitters. 

9.2.7 Check the Load 

Select Screen Settings and then select the Output tab. Under Port Load, click  next to the device information to 

check the usage of the controller's loading capacity. 
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Figure 9-12 Port load 
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10 Screen Monitoring 

10.1 Check Device Status 

Select Monitor and click the function icons on the left to check the related information. 

Figure 10-1 Monitoring 

 

Note 

When you select the first four of the following function icons: 

 The topologies in different colors have different meanings. Please see the explanation at the bottom right. 

 In the properties area, you can set the cabinet display image to blackout, freeze or a test pattern. 

 : The overall status. 

 : The receiving card temperature.  

 : The cabinet voltage. In the properties area, you can check the detailed voltage value. 

 : The total bit errors. In the properties area, you can check the detailed total errors, click  to clear the 

errors and let errors accumulate from zero, and click  to check the error information in a specified 

time range. 

 : The controller. In the topology area and properties area, check the controller related information, as shown 

in Figure 10-2. If you set the Controller Finder switch to , you can enable the controller finder function. 

XI'
AN
 N
OV
AS
TA
R T
EC
H 
CO
., L
TD
.



 VMP Vision Management Platform User Manual  
   

 

www.novastar.tech   32 
 

 

Figure 10-2 Controller information 

 

10.2 Check Monitoring Records 

Select Monitor and at the bottom of the page, do the operation as needed. 

Figure 10-3 Monitoring records 

 

 Search records 

Enter the key words in the search box. 

 Query records 

Click the time widget and set the start and end time. If you select Now, the monitoring records will be updated in 

real time. 

 Set how the records are displayed 

From the drop-down list, select Tile, Order by controller, Order by type. If the latter two are selected, the 

records can be expanded or collapsed. 

 Clear records 

Click Delete and click OK. 

 Export records 

Click Export, select a location and click Save. 
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11 Preset Management 

11.1 Save Presets 

After completing the display effect adjustment, you can save the data on the Source, Layout, Processing and 
Screen Settings pages as presets so that these data can be directly applied in the future. The preset of a specific 

device can only be applied by this device itself and the preset of a group can be applied by all the devices in the 
group. 

Step 1 Choose Preset. 

Step 2 On the preset management page, click  to enter the page shown in Figure 11-1. 

To go back to the preset management page, click a blank area in the properties area. 

Figure 11-1 Preset management 

 

Step 3 Click a preset icon. In the properties area, set a name for the preset and select the data you need to save. 

If the preset you selected is not a blank one, the original data will be overwritten. 

Step 4 Click Save. 

11.2 Apply Presets 

Apply a saved preset to quickly complete settings of the parameters on the Source, Layout, Processing and 
Screen Settings pages. The preset of a specific device can only be applied by this device itself and the preset of a 

group can be applied by all the devices in the group. 

Step 1 Choose Preset. 

Step 2 On the preset management page, double click a preset and wait it to be loaded. 

The preset that is being used has a  at the top right. 

Figure 11-2 Applying presets 
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11.3 Manage Presets 

Select Preset and do the following operations as needed. 

Modify a Preset 

Select a preset. In the properties area, change the related information and click Save. 

Delete a Preset 

 Right click a preset and select Delete from the pop-up menu. 

 On the preset management page, select a preset and click Delete in the properties area. 

Clear Presets 

Right click a preset and select Delete All from the pop-up menu. 

11.4 Import and Export Presets 

Select Preset and do the following operations as needed. 

Import Presets 

Click Import, select a preset file (.nprt) and click Open. In the displayed dialog box, select the device to which you 
want to import the file and click Ok. 

 

Export Presets 

Click Export, select a location, set a file name, and click Save. 
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12 Screen Maintenance 

12.1 Maintain Controllers 

From the menu bar, choose Tools > Maintain and do the following operations as needed. 

Figure 12-1 Controller maintenance 

 

Operations in Device List 

In the device list, right click a controller. In the pop-up menu, select Controller Properties to open its dialog box. 

Figure 12-2 Controller properties 

 

 Check the basic information 

Check the controller model, SN, firmware version, IP address, MAC address, etc. 

 Check the detailed information 

Click  to expand the panel and check the detailed controller hardware and software information. 

 Change the time 

Click the time widget and change the time. 

 Change the time zone 

Select a time zone from the Time zone drop-down list. 
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 Export logs 

Click Export Log, select a location, set the file name, and click Save. 

After you right click a controller in the device list, you can also do the following operations. 

 Rename the controller 

In the pop-up menu, select Rename and rename the controller. 

 Enable Mapping 

In the pop-up menu, select Mapping and the Mapping function is enabled. It allows users to easily obtain the 

locations and connection topology of receiving cards. 

Operations on Controller Maintenance Tab Page 

In the device list on the left, select a controller or a group. On the Controller tab page, select the target controllers 

and then do the operations. 

 Find the controller 

This function marks the area loaded by the controller on the LED screen and the LCD screen of the controller 
becomes green, which helps you find the controller quickly. 

Click Controller Finder. 

 Upgrade the firmware program 

Click Upgrade, select the firmware file (.img) and click Open. 

During the upgrade process, the controller will automatically restart. In addition, please do not close VMP or 
switch to another controller until the upgrade is complete. 

 Restart the controller 

Click Restart and click OK. 

 Reset settings (operate with caution) 

Click Reset and click OK. 

 Upload the full screen coefficients 

Click Upload full screen coefficient, select the full screen calibration database file (.db) and click Open. 

12.2 Maintain Cabinets 

From the menu bar, choose Tools > Maintain and select the Cabinet tab. In the device list, select the target 

controllers and do the following operations on the cabinets as needed. 

Figure 12-3 Cabinet maintenance 
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Select the target cabinets and then do the operations. 

 Check the cabinet information 

Check the cabinet status, manufacturer, model, firmware version, location etc. 

 Copy the firmware program and configuration file 

Click Cabinet Painter and select other cabinets so that other cabinets can have the same firmware program 

and configuration file as the current cabinet. 

 Update the cabinet 

Use the cabinet library file to update the cabinet firmware program and configuration file. 

a. From the menu bar, choose Settings > Cabinet Library. 

 

b. Click Import, select a cabinet library file (.ncp) and click Open. 

To delete the imported data, select the data and click Delete. 

c. On the Cabinet tab page, select one or multiple cabinets and click Update. 

 

d. Select the target row of cabinet data and click OK. 

 Restart the cabinet 

Click Restart and click OK. 

 Upgrade the firmware program 

Click Upload File, select Upgrade firmware from the drop-down menu, select a firmware program package 
(.zip/rar) and click Open. 

 Upload the configuration file 

Click Upload File, select Upgrade Config file from the drop-down menu, select a configuration file (.rcfgx) and 
click Open. 
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After the file is uploaded, click Save Rv-card config. For CX series products, this operation is not required. 

 Upload the image quality file 

Click Upload File, select Upload Image Quality File from the drop-down menu, select an image quality file 
(.nrf/.vglcx) and click Open. 

After the file is uploaded, click Save Rv-card config. For CX series products, this operation is not required. 

 Save or read back the module calibration coefficients 

Click LDM coefficient, select Save to LDM or Read to Rv card from the drop-down menu to save the module 

calibration coefficients from the receiving card to the module or read the coefficients from the module to the 
receiving card. 

 Upload or erase the cabinet calibration coefficients 

Click Cabinet coefficient and select Upload or Erase from the drop-down menu 

 Refresh information 

Click Refresh. 

 Upload the full screen coefficients 

Click Upload full screen coefficient, select the full screen calibration database file (.db) and click Open. 

 Find the cabinet 

Click Cabinet Finder in the Action column. This function helps you find the cabinet on the screen quickly. 
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13 Software Settings 

13.1 Change the Display Language 

From the menu bar, choose Settings > Language, select the target language and click OK. 

Figure 13-1 Changing the display language 

 

13.2 Check the User Manual 

From the menu bar, choose Help > User Manual to open and check the VMP user manual. 

13.3 View Software Information 

From the menu bar, choose Help > About and view the software information. 
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